Back to overview
Degraded
Service Interruption to Incoming Calls
Jun 13 at 01:34pm UTC
Resolved
Jun 13 at 01:54pm UTC
We have identified a routing issue between Xneelo and another datacentre. We have re-routed the traffic and the situation has stabilised.
Affected services
Created
Jun 13 at 01:34pm UTC
We are aware of delays in handling incoming calls for customers with their voice hosted in Xneelo. We are investigating.
Affected services