Back to overview
Degraded

Xneelo Voice Connectivity

Feb 21 at 12:07pm UTC

Resolved
Feb 21 at 12:11pm UTC

Network conditions have improved, and we are seeing calls completing successfuly. We are awaiting confirmation from Xneelo of the cause.

Created
Feb 21 at 12:07pm UTC

We are investigating issues with Xneelo connectivity