Back to overview

Intermittent slowness

Sep 08 at 09:44am UTC
Affected services
Data Region - Azure ZA North A (JNB)

Resolved
Sep 08 at 09:51am UTC

We are seeing normal speed consistently over past 5 minutes - we continue to investigate cause

Created
Sep 08 at 09:44am UTC

We are investigating