Cloudflare / Google Cloud Outage
Resolved
Jun 12 at 09:02pm UTC
In summary
Google Cloud had an incident which in turn affected Cloudflare. This resulted in errors or slow requests across many websites, and may have affected your customer's abilities to access your website and start a live chat.
Affected services
Updated
Jun 12 at 09:02pm UTC
Final update from Cloudflare
All Cloudflare services have been restored and are now fully operational. We are moving the incident to Monitoring while we watch platform metrics to confirm sustained stability.
Affected services
Updated
Jun 12 at 08:35pm UTC
Latest from Cloudflare
Cloudflare services are recovering quickly around the globe. WARP and Turnstile are operational, though a small residual impact remains and we’re working to eliminate it. The core KV service is restored, bringing dependent products back online. We expect further recovery over the next few minutes and a steady drop in impact.
Affected services
Updated
Jun 12 at 08:25pm UTC
We are seeing service levels returning to normal for Cloudflare on latency and error rates.
Affected services
Updated
Jun 12 at 08:11pm UTC
Update from GCP
All locations except us-central1 have fully recovered. us-central1 is mostly recovered. We do not have an ETA for full recovery in us-central1.
Affected services
Updated
Jun 12 at 08:07pm UTC
Update from Cloudflare
Cloudflare’s critical Workers KV service went offline due to an outage of a 3rd party service that is a key dependency. As a result, certain Cloudflare products that rely on KV service to store and disseminate information are unavailable including:
Access
WARP
Browser Isolation
Browser Rendering
Durable Objects (SQLite backed Durable Objects only)
Workers KV
Realtime
Workers AI
Stream
Parts of the Cloudflare dashboard
Turnstile
AI Gateway
AutoRAG
Cloudflare engineers are working to restore services immediately. We are aware of the deep impact this outage has caused and are working with all hands on deck to restore all services as quickly as possible.
Affected services
Updated
Jun 12 at 07:40pm UTC
Update from Cloudflare
We are starting to see services recover. We still expect to see intermittent errors across the impacted services as systems handle retried and caches are filled.
Update from GCP
Incident affecting Agent Assist, AlloyDB for PostgreSQL, Apigee, Cloud Data Fusion, Cloud Firestore, Cloud Memorystore, Cloud Shell, Cloud Workstations, Contact Center Insights, Dialogflow CX, Dialogflow ES, Google App Engine, Google BigQuery, Google Cloud Bigtable, Google Cloud Console, Google Cloud Dataproc, Google Cloud SQL, Google Cloud Storage, Identity Platform, Identity and Access Management, Memorystore for Memcached, Memorystore for Redis, Memorystore for Redis Cluster, Speech-to-Text, Text-to-Speech, Vertex AI Search
Multiple GCP products are experiencing Service issues
Incident began at 2025-06-12 10:51 (all times are US/Pacific).
Currently affected location(s)
Johannesburg (africa-south1)Multi-region: asiaTaiwan (asia-east1)Hong Kong (asia-east2)Tokyo (asia-northeast1)Osaka (asia-northeast2)Seoul (asia-northeast3)Mumbai (asia-south1)Delhi (asia-south2)Singapore (asia-southeast1)Jakarta (asia-southeast2)Multi-region: asia1Sydney (australia-southeast1)Melbourne (australia-southeast2)Multi-region: euMulti-region: eur3Multi-region: eur4Warsaw (europe-central2)Finland (europe-north1)Stockholm (europe-north2)Madrid (europe-southwest1)Belgium (europe-west1)Berlin (europe-west10)Turin (europe-west12)London (europe-west2)Frankfurt (europe-west3)Netherlands (europe-west4)Zurich (europe-west6)Milan (europe-west8)Paris (europe-west9)GlobalDoha (me-central1)Dammam (me-central2)Tel Aviv (me-west1)Multi-region: nam5Montréal (northamerica-northeast1)Toronto (northamerica-northeast2)Mexico (northamerica-south1)São Paulo (southamerica-east1)Santiago (southamerica-west1)Multi-region: usIowa (us-central1)South Carolina (us-east1)Northern Virginia (us-east4)Columbus (us-east5)Dallas (us-south1)Oregon (us-west1)Los Angeles (us-west2)Salt Lake City (us-west3)Las Vegas (us-west4)
Affected services
Updated
Jun 12 at 06:20pm UTC
There is currently a widespread Cloudflare and Google Cloud Platform outage which may be affecting your connectivity to websites hosted behind these services.
https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW
https://www.cloudflarestatus.com/
Azure is unaffected
Affected services
Created
Jun 12 at 06:04pm UTC
We are seeing issues with connecting to Cloudflare. Investigating
Affected services