Back to overview

MTN and Liquid Telecom Interconnect

Oct 22 at 03:14pm UTC
Affected services
Voice - ZA North (JNB)

Resolved
Oct 23 at 07:11am UTC

This has been confirmed as resolved.

Updated
Oct 23 at 06:16am UTC

Liquid confirm the issue has been raised with MTN as a priority issue, but no ETA on resolution at present

Created
Oct 22 at 03:14pm UTC

We are aware of an interconnection issue between Liquid Telecom and MTN. This is disrupting outbound and inbound calls using 060 numbers and MTN. This is due to a failure of an SS7 link between the carriers. We have no ETA yet on resolution.

Please note, this is a carrier issue rather than something within QContact's control. This affects all traffic between Liquid Telecom and MTN.