Back to overview
Degraded
Angani Voice
Sep 30 at 09:10pm UTC
Resolved
Sep 30 at 10:46pm UTC
Angani have resolved the issue
Affected services
Created
Sep 30 at 09:10pm UTC
We are aware of an incident with Angani causing loss of service in Kenya. We are awaiting on details from Angani
Affected services