Back to overview
Degraded

Kenyan connectivity issues

Jun 25 at 02:02pm UTC

Resolved
Jun 26 at 09:00am UTC

We see no further issues at this time, and the datacentre has confirmed it should now remain stable.

Updated
Jun 26 at 08:50am UTC

We are seeing intermittent network connectivity issues reoccurring - we will continue to monitor, but this is most likely related to previous advisories.

Updated
Jun 26 at 05:03am UTC

We continue to see stable connectivity into Kenya from Europe, but connectivity from South Africa remains degraded in part.

We will continue to monitor the situation, however for now we are closing this issue as fully resolved as connectivity has in the most part been fully restored and stable for over 12 hours.

Updated
Jun 25 at 09:00pm UTC

We continue to see improvements with no packet loss now being seen from any of our monitoring stations. We will continue to monitor overnight.

Updated
Jun 25 at 08:56pm UTC

We are now seeing under 1% packet loss from South Africa. We will continue to monitor the situation.

Updated
Jun 25 at 08:42pm UTC

We have seen connectivity now restored from Europe via Djibouti with no packet loss. Packet loss from South Africa has significantly improved but remains elevated (from ~50% loss to under 10%).

Remote users using Kenyan voice services located in Europe should now have normal service. Users of QContact's web browser interface should also now have acceptable voice quality as the voice codecs we use will handle 10% with minimal disruption.

We will continue to monitor connectivity improvements from other African countries.

Updated
Jun 25 at 04:20pm UTC

Airtel have confirmed they are also experiencing similar issues with connectivity at present https://x.com/AIRTEL_KE/status/1805635373680193836

Updated
Jun 25 at 03:12pm UTC

Safaricom has indicated they have been hit by multiple subsea cable failures. There is no ETA at present.

Updated
Jun 25 at 02:58pm UTC

Safaricom have provided an update https://x.com/SafaricomPLC/status/1805615681951375595

There is a complete loss of connectivity from Europe, but there is some connectivity with very high packet loss from South Africa being routed over MTN Business. Remote users of Kenyan voice services located outside of the country may be unable to use voice services at this time.

Created
Jun 25 at 02:02pm UTC

There is currently an international connectivity event in Kenya - we are awaiting on further details.