Back to overview
Degraded
SSO
May 29 at 07:27am UTC
Affected services
WhatsApp
Resolved
May 29 at 08:13am UTC
The update has been fully deployed in all regions.
Affected services
Updated
May 29 at 07:57am UTC
We are deploying an update to resolve this issue.
Affected services
Created
May 29 at 07:27am UTC
We are investigating an issue with Microsoft Entra ID SSO
Affected services