Back to overview
Degraded
Slow Requests
Apr 15 at 09:39am UTC
Resolved
Apr 15 at 10:13am UTC
Requests are now all processing at normal speed. There is a delay on workflows still as the backlog is cleared.
Affected services
Updated
Apr 15 at 10:01am UTC
Most requests are now resolving quickly but some requests are still taking longer than usual to run
Affected services
Updated
Apr 15 at 09:41am UTC
We have identified the cause and are working on a resolution
Affected services
Created
Apr 15 at 09:39am UTC
We are seeing slow requests and investigating
Affected services