Back to overview
Degraded

Meta Service Issue

Apr 03 at 06:10pm UTC
Affected services
WhatsApp

Resolved
Apr 03 at 08:45pm UTC

Meta have confirmed the issue is resolved.

The fix for the outage impacting service on Cloud API has been deployed and this issue is now mitigated as of 04-03-2024 at 1:45 PM PST. Thank you for your patience.

Created
Apr 03 at 06:10pm UTC

There is currently disruption with Meta services globally. This is affecting message delivery on Facebook, Instagram and WhatsApp.

Waiting on an update from Meta who will post at https://metastatus.com/whatsapp-business-api