Back to overview
Degraded
Meta Disruptions
Mar 05 at 04:00pm UTC
Affected services
WhatsApp
Resolved
Mar 05 at 09:00pm UTC
Meta have confirmed all services are restored to normal
Affected services
Updated
Mar 05 at 04:48pm UTC
Meta have updated the incident to say they are recovering.
Affected services
Created
Mar 05 at 04:00pm UTC
Meta is experiencing a large service disruption which may be affecting WhatsApp, Facebook and Instagram services at this time
More details are posted at https://metastatus.com/
Affected services