Back to overview
Degraded
Outbound UK Calling
Dec 14 at 02:18pm UTC
Affected services
Voice - UK South (LHR)
Resolved
Dec 14 at 02:40pm UTC
This has been resolved by the upstream telephone carrier.
Affected services
Created
Dec 14 at 02:18pm UTC
We are aware of issues outbound calling at present to UK destinations. This is an upstream carrier issue, and has been raised with them.
Affected services