Back to overview
Degraded

MTN Numbers

Sep 10 at 11:45am UTC
Affected services
Voice - ZA North (JNB)

Resolved
Sep 10 at 01:34pm UTC

We are seeing calls connecting successful at present. We will continue to monitor, but we are marking the issue as resolved.

Created
Sep 10 at 11:45am UTC

We are aware of an issue with some MTN numbers not connecting. This is an issue with MTN's voice network, and is affecting calls from both landlines and mobiles. If you have an MTN hosted number, your service may currently be disrupted. For further details please contact your MTN account manager, as this issue is outside of QContact.